Dick Cappels' project pages http://www.projects.cappels.org
Return to HOME (Go to Wide Range of Topics on cappels.org)

The emachine EM250 or D250 with Linux
- getting the best out of it?

Find updates at http://www.cappels.org/wide_range_of_topics/Home.htm
Contributed by Puddledud.

The Article

This machine is rather under powered but if you have one lying about and are prepared to put in a bit of effort then it may still be useful. At the end of the day the benchmarks, as measured with the "System Profiler and Benchmark" application, are below that of a Celeron running at 1.5 GHz. (That is with only the memory maxed out not with any other possible hardware improvements.)

There are three things to be done with the hardware as far as I can see:

* max out the memory to 2GB
  this is just good for the machine overall - a must do.

* install the Broadcom crystalhd mini pcie card BCM70015, at the cost of losing wireless. This WiFi loss can be remedied by fitting either a usb WiFi adaptor or a Bluetooth dongle.

Getting the Broadcom crystalhd drivers working turned out to be a bit of a marathon. I recommend this site:


which references and adds to the intructions given on this site:


The suggested patch works well.

My recommendation is to have nothing to do with the linux drivers on the Broadcom site. The drivers in this 'how to install' referred to come from:

git clone git://git.linuxtv.org/jarod/crystalhd.git

It is a major error of judgement to try to use the Broadcom download sourced drivers instead of these ones.

(As long as a user can follow instructions precisely the installation is doable - but it does call for the ability to use the treminal command line.)

In terms of the result achieved, the Broadcom crystalhd video card is wonderful but it does not make a noticable difference to the base line machine performance benchmarks.

* replace the hard drive with an SSD drive

I have purchased a 2 in 1 Mini PCIE 2 Lane M.2 and mSATA SSD to SATA III 7+15 Pin Adaptor card but have yet to get either an M2 or msata SSD drive so this step is one I still aspire to.

I tried a number of different linux versions.

Vine worked well but in the end I gave up on it due to difficulties I had trying to install software not to be found in the repositories, the lack of accessible online help in English and some residual effects which cropped up at times due to the closely controlled flavour of Linux and its references back to the Japanese LOCALE. It remains a wonderful Linux environment.

After that I tried several different Linux varieties including Linux Mint Cinamon 17.3, which didn't manage to install successfully.

Some of the other versions I tried did load successfully but made a woeful job of setting up the screen resolution of both the D250 monitor and the much larger external monitor, most offered a 'best' solution of 'mirrored screens' locked together at 800X600.

I concluded that it was necessary to look for a distribution that had a substantial userbase in order to get the depth of development and the reliability that I was looking for and settled on Linux Mint 17.3 xfce.

To my delight, this version - Linux Mint 17.3 xfce - loaded without issues and did the best job of all the linuxes I'd tried in sorting out the resolution discrepencies between the two monitors. The external monitor now displays at 1366X768 and the D250 screen at 1024X600.

Once this was achieved I set to to tailor the installation.

This meant turning off a lot of effects that I didn't want - chat, torrent, cloud services etc.

I found a very useful posting on things to do after installing Linux Mint at:


and I recommend it to the attention of those doing something similar to what I describe here.

There are also some other off shoots of that page leading to other fruitful avenues to explore and detailing further tweeks to be carried out.

It so happens that there are two Windows world applications that I am loath to do without - Pegassus Mail and Ifranview. Both will install and run under wine and so I set to to make them available.

Wine works very well under Linux, it is simply a matter of making sure that the package is installed and then at a terminal window executing a command of the type $ wine iview441_setup.exe or $ wine w32-471.exe (I did need to make the MFC42.DLL available in the same location as the iview441_setup.exe file and there are probably licencing issues associated with use of the MFC42.DLL - so check the legality of using that dll out for yourself before you take the step!)

A note of warning, I found winetricks less than useful, deciding to uninstall winetricks and reinstall wine. That fixed the issues I was having with the installation of Ifranview and then it just worked. I found the 'locked in' downloading of files from CNET associated with winetricks to be a real irritation.

I also decided that I didn't need q4wine.

Pegasus Mail is running under this system and quite usable but the aplication does not run as smoothly as another instance I have on a more capable Linux machine.

Ifranview installs smoothly and runs very well.

Physical setup of the home Network:

This emachine D250 that I am working with is connected - usually - to the second of two routers each of which runs a router based firewall - a Draytek 2800vg initially and then a Draytek 2820. The logic is that it removes the firewall load from the D250 and creates two zones - one of which can be run at a reduced security level.

This posting was very useful in sorting out the two router concept.


There is an issue with ipv4 or ipv6 protocol as the Draytek Vigor 2800 VG only does ipv4 but in practice it doesn't cause difficulty and I don't recollect whether I had to set the Draytek 2820 to use ipv4 or whether it just copes - I think the latter.

The complexity of the settings available on the Draytek 2820 is misleading at first sight but reading the manual and digging a bit deeper reveals a wealth of functionality - a much more comprehensive offering than is to be found on the Vigor 2800 model. One nice feature of the Draytek 2820 is a second WAN ethernet connection which was the big attraction to me in this instance.


I found that once I'd installed Firefox together with addons NOSCRIPT, HTTPSEVERYWHERE, QuickJS and AdBlock Plus that some of the sites I wanted to access didn't want to play. The message referring me to the administrator who had blocked the particular site was a common occurrence.

Fault finding this site blocking issue is not a trivial task as there are two router firewalls, the firefox preferences and the firefox addons to be considered - the task is ongoing. I have still not worked out what it is that sites take such exception to although I have decided that it may have nothing to do with the routers - for a Windows XP machine - plugged into the same routers doesn't experience the same difficulties and neither does the Tor browser operating from the same router connection experience the same level of difficulty.

An unusual solution to intransigent sites blocking access.

I installed the Tor browser and found that if I ran that at the minimal security level setting that I was able to successfully access nearly all of the sites which had been causing me difficulty.

The access is a bit slow but the activity I was after is essentially just web browsing and it works.

At that point I decided to tailor things a bit further and set the Tor browser up to both start with the particular url I wanted and to display an icon appropriate to the site I had it set to.

[It is posible to restrict TOR to just one link - I went one step further, tried for 0 steps and came undone. The nodes providing the links can opt to accept connections based on the number of links - as I understand it - and it may take a long time to find one willing to take a one jump link so it turns out to be less than useful as a mechanism for speeding up the connection by reducing the number of steps.] 

Some nitty gritty:

### multiple file delete by piping find output to rm

Really useful to make entirely sure that things have in fact been deleted - BUT VERY DANGEROUS!


find -type f -name something | xargs rm -irf

### XSS filter for ebay - from XSS help in NOSCRIPT


note the country options in the matching pattern - particularly if your location is something different to those given.

### edited start-tor-browser in /home/<someone>/Downloads/tor-browser_en-US/Browser/

replace ./firefox with ./firefox http://www.ebay.com.au

Remember to put a space after the url in the replacement. This seems to be an efficient mechanism and if files are overwritten with updates I would hope that the worst outcome would be that Tor would revert to its default operation. If you choose to do it though and it goes wrong be it upon your own head!

The change means that TOR will start directly with ebay as its homepage - until or unless the edited files get over written with an update!

### changed the display icon for Tor so that it displays a message appropriate to the default destination

made a blue background with text icon showing ebay - used the gimp

export the jpg as a png file using the gimp

go to the icon directory


copy the new icon as a png file into the that directory

rename the old Tor icon

rename the new icon to be named as the old Tor icon was

make sure to keep backups of both icons.

restart the computer to have the change take effect

[I've had a look at two different versions of Tor - the one I edited was the tor-browser-linux32-5.5.2_en-US.tar.xz. Another version which I downloaded  tor- proved to be setup differently and the editing I carried out could not be done in the same way with that version. Tor is not really a sensible option for browsing ebay although there is an element of the absurd in having ebay locate the access to be coming from Poland!]

This is what the emachine external monitor currently looks like:


In conclusion, The machine is surprisingly capable but a bit kludgy at times. When I set it to compile the source for tor- it chugged away for a long time - of the order of twenty minutes or more, I didn't really time it - but it did do the job. At times I notice some latency in text appearing in editable boxes in firefox and am not sure what causes this - whether it may be processing delay or be down to network latency due to having a US site viz:  http://encrypted.google.com/ set as a home page. I wonder whether there would be a performance increase sufficient to make this glitch go away if an SSD was to be installed?

An Addendum:

I found that it is easy to update the Draytek router software using the linux environment.
 How to upgrade firmware in a Draytek router: 2800; 2820


How to restore a Draytek router to factory status.
(Should I say - a final resort way to restore a router to factory status.)


Upgrade Utility: FrmUpg.exe
(Currently version V4.3.0)

Firmware upgrade software:

eg:V2820_3376_STD_A.all or v28va282.all


V2820_3376_STD_A.rst or v28va282.rst

A computer running linux with wine - the Linux Windows emulator - installed.

Distinction to be noted:

The firmware upgrades come in a zipped archive and contain two versions of the upgrade file - one with a <XXXX>.all file type and the other with a <XXXX>.rst file type.
[ It is worth noting that the upgrade files are region specific, Australian files are sourced from Australian support and English files are sourced from support in England.]

These two files have different functions. The .all file will retain the user settings when installed but the rst file will wipe out all user settings and restore the unit to factory status. (Each file contains essentially the same content apart from this end function distinction.)


put the files on the linux computer - I found the Desktop a convenient location

open a terminal window

become the root user     #su         <enter>
            #<password>    <enter>

set the directory for the terminal to the Desktop

            #cd /home/<user>/Desktop

(make sure that the computer has an ethernet connection to the router.)

            #wine FrmUpg.exe

Once the upgrade utility window loads opt to browse to select the Router IP.
(It is better to browse to select it than to type it in.)

Browse once again to choose the Firmware file.

(NB: the default seems to be the .all file and it is often necessary to set the .rst prefix before that file becomes visible when looking for it in the extracted archive.)

Type in the password in the editable box.

(I'm not sure that a password is needed for the rst file version but I tended to use the default factory condition password for the particular router.)

Click the  Send button

Wait patiently for the utility to check the conditions, for the router to become available, for the software to be transferred using tftp, for the router to then copy the newly downloaded file into place and finally for the router to reboot.

When the whole process is finished it will display a message to say that the router is once again up.

By the way:

I found that it is much easier to do such a firmware upgrade under Linux than under Windows.


When logging on to the web interfaces of such routers I found it an advantage to run Firefox with root privilege under Linux. viz: #firefox

(When running Firefox without root privilege I was unable to log in to the router. Later on I found that the router was quite happy to accept the same username and password when Firefox was run under root privilege thta it had previously rejected. My conclusion is therefore that there may in fact be nothing wrong with a stubbornly resistent router - a problem in logging in may simply be down to the authority granted the application with which a user is trying to access it.)

If the router has been reset to the default username and password but remains inaccessible, repeatedly denying login attempts, then this could well be the cause!

I did,once, find it necessary to reset the laptop ip address when it told me that the router was unreachable and I found these commands - on the net - to do so. (The problem was due to moving the Linux box from one router to another and happened because the two routers had very different ip address allocation ranges.)

             $sudo dhclient -r
        ( to get rid of the persistent ip address causing the problem.)

            $sudo dhclient
        (to have a new ip address allocated.)


20th Feb 2016

Return to HOME (Go to Wide Range of Topics on cappels.org)

Article copyright ©2012 by Puddledud. First posted on August 12, 2012 on cappels.org
Return to HOME

You can send  email to Dick Cappels at projects(at)cappels.org. Replace "(at)" with "@" before mailing. I can forward email to Puddledud.

Keywords: Linux security, keyboard remap, security enhancement, password security, Linux password,
  Liability Disclaimer and intellectual property notice
(Summary: No warranties, use these pages at your own risk. You may use the information provided here for personal and educational purposes but you may not republish or use this information for any commercial purpose without explicit permission.) I neither express nor imply any warranty for the quality, fitness for any particular purpose or  user, or freedom from patents or other restrictions on the rights of use of any software, firmware, hardware, design, service,information, or advice provided, mentioned,or made reference to in these pages. By utilizing or relying on software, firmware, hardware, design, service,information, or advice provided, mentioned, or made reference to in these pages, the user takes responsibility to assume all risk and associated with said activity and hold Richard Cappels harmless in the event of any loss or expense associated with said activity. The contents of this web site, unless otherwise noted, is copyrighted by Richard Cappels. Use of information presented on this site for personal, nonprofit educational and noncommercial use is encouraged, but unless explicitly stated with respect to particular material, the material itself may not be republished or used directly for commercial purposes. For the purposes of this notice, copying binary data resulting from program files, including assembly source code and object (hex) files into semiconductor memories for personal, nonprofit educational or other noncommercial use is not considered republishing. Entities desiring to use any material published in this pages for commercial purposes should contact the respective copyright holder(s).

Free Counter
Free Counter